Issue details:

Solaris ldap client doesn’t work. you can use ldaplist/ldapclient even ps will hang

Solutions:

kill the ldap_cachemgr.

root # file /var/run/ldap_cache_door

/var/run/ldap_cache_door: door to ldap_cachemgr[1299]

kill 1299

then bounce the ldapclient, more details to trace the issue.

`
root # truss ldaplist
execve(“/usr/bin/ldaplist”, 0xFFBFFB74, 0xFFBFFB7C) argc = 1
sysinfo(SI_MACHINE, “sun4v”, 257) = 6
…. = 0
brk(0x0002CC58) = 0
open(“/var/run/ldap_cache_door”, O_RDONLY) = 3
fcntl(3, F_SETFD, 0x00000001) = 0
door_info(3, 0xFF35A248) = 0
door_call(3, 0xFFBFEBB8) (sleeping…)
^C Received signal #2, SIGINT, in door_call() [default]</p>

root # file /var/run/ldap_cache_door
/var/run/ldap_cache_door: door to ldap_cachemgr[1299]

root # ps -ef|grep ldap (hang)
^C
root # ls /proc/1299/
as ctl lstatus object/ psinfo status
auxv cwd/ lusage pagedata rmap usage
contracts/ fd/ lwp/ path/ root/ watch
cred lpsinfo map priv sigact xmap

root # cat /proc/1299/psinfo
<P¦¦PR¦f<¦" ¦6¦ldap_cachemgr/usr/lib/ldap/ldap_cachemgr¦d¦lUpS(;PR¦[>¦¦TS0¦¦¦¦unwas01c:ConfigureLdap root #

root # svcs |grep ldap
legacy_run Sep_14 lrc:/etc/rc3_d/S85ldapclient
maintenance 3:54:22 svc:/network/ldap/client:default

root # kill 1299

Nov 7 04:10:43 host01 ls[20489]: libsldap: makeConnection: unable to make LDAP connection, request for a server failed: (Unable to load configuration '/var/ldap/ldap_client_file' ('').)
Nov 7 04:10:43 host01 ls[21109]: libsldap: makeConnection: unable to make LDAP connection, request for a server failed: (Unable to load configuration '/var/ldap/ldap_client_file' ('').)
Nov 7 04:10:43 host01 ls[21323]: libsldap: makeConnection: unable to make LDAP connection, request for a server failed: (Unable to load configuration '/var/ldap/ldap_client_file' ('').)
Nov 7 04:10:43 host01 ls[20911]: libsldap: makeConnection: unable to make LDAP connection, request for a server failed: (Unable to load configuration '/var/ldap/ldap_client_file' ('').)

Total: 2623 processes, 5037 lwps, load averages: 0.22, 0.23, 0.22

root # svcadm clear svc:/network/ldap/client
root # svcs
....
online 4:11:15 svc:/network/ldap/client:default
maintenance Sep_14 svc:/network/samba:default
maintenance Sep_14 svc:/network/wins:default

root #
`